Flight tracking — degraded performance

Incident Report for FlightCrewPro

Resolved

Flight tracking is operating normally again.
Posted Aug 29, 2026 - 11:35 UTC

Investigating

1 of 20 flight-data sources are not reporting. Live positions, gate times, delays, and inbound aircraft may be missing for some flights or update more slowly than usual.
Posted Aug 29, 2026 - 11:00 UTC